8. Электронные таблицы 2. Функции в ЭТ. Задачи ГИА 1. (2009

Реклама
8. Электронные таблицы
2. Функции в ЭТ.
Задачи ГИА
1. (2009) После проведения олимпиады по информатике жюри олимпиады
внесло результаты всех участников олимпиады в электронную таблицу.
На рисунке приведены первые строки получившейся таблицы:
1
2
3
4
A
Фамилия
Корнеев
Васильев
Лебедев
B
Имя
Сергей
Игорь
Николай
C
Класс
9А
9А
9Б
D
Зад. 1
7
10
3
E
Зад. 2
10
3
7
F
Зад. 3
4
7
10
G
Зад. 4
0
4
4
H
I
В столбце A электронной таблицы записана фамилия участника, в столбце B — имя
участника, в столбце C — класс, в котором учится участник, в столбцах D, E, F и G — оценки
каждого участника, полученные за каждую из четырех задач, предлагавшихся на олимпиаде.
Всего в электронную таблицу были занесены результаты 100 участников. По данным
результатам жюри хочет определить победителя олимпиады и трех лучших участников.
Победитель и лучшие участники определяется по сумме всех баллов, а при равенстве баллов
— по количеству полностью решенных задач (чем больше задач решил участник полностью,
тем выше его положение в таблице при равной сумме баллов). Задача считается полностью
решена, если за нее выставлена оценка 10 баллов.
Выполните задание
Откройте файл с данной электронной таблицей (расположение файла вам сообщат
организаторы экзамена). После этого отсортируйте данную таблицу в порядке уменьшения
результатов участников, то есть по уменьшению количества баллов, а при равном количестве
баллов у участников — по уменьшению количества верно решенных задач. При этом первая
строка таблицы, содержащая заголовки столбцов, должна остаться на своем месте.
Полученную таблицу необходимо сохранить в каталоге под именем, указанным
организаторами экзамена.
Решение
Сначала в столбец H запишем сумму баллов, набранных каждым из участников. Для
этого в ячейку H1 запишем заголовок столбца «Сумма баллов», в ячейку H2 запишем
формулу для подсчета суммы баллов для участника в строке 2: =СУММ(D2:G2). Скопируем
ячейку H2 в буфер обмена, выделим блок H3:H101 и вставим в этот блок содержимое буфера
обмена. Благодаря использованию относительных ссылок, в столбце H для строк 2–101 будет
записана сумма баллов для каждого участника.
Затем в столбец I запишем количество задач, полностью решенных участником. Для
этого в ячейку I1 запишем заголовок столбца «Решено задач» и запишем в ячейку I2 формулу
=СЧЕТЕСЛИ(D2:G2;"=10"). После этого скопируем эту ячейку и вставим ее в блок I3:I101. Мы
подсчитали для каждого участника сумму полученных им баллов (в столбце H) и количество
решенных задач (в столбце I). Выполним настраиваемую сортировку таблицы по убыванию
значения суммы баллов (столбец H), а при равных значениях в столбце H — по убыванию
количества решенных задач (столбец I):
После сортировки в верхней строке (строка 2) будет записано имя победителя
олимпиады, а в последующих строках — призеров олимпиады.
2. (2010) Результаты сдачи выпускных экзаменов по алгебре, русскому языку, физике и
информатике учащимися 9 класса некоторого города были занесены в электронную
таблицу. На рисунке приведены первые строки получившейся таблицы:
A
B
C
D
E
F
G
1
Фамилия
Имя
Алгебра Русский Физика Информатика
2
Абапольников Роман
4
3
5
3
3
Абрамов
Кирилл
2
3
3
4
4
Авдонин
Николай 4
3
4
3
В столбце A электронной таблицы записана фамилия участника, в столбце B — имя
участника, в столбцах С, D, E и F — оценки учащегося по алгебре, русскому языку, физике и
информатике. Оценки могут принимать значения от 2 до 5. Всего в электронную таблицу
были занесены результаты 100 учащихся.
Выполните задание
Откройте файл с данной электронной таблицей (расположение файла вам сообщат
организаторы экзамена). На основании данных, содержащихся в этой таблице, ответьте на
два вопроса:
1. Какое количество учащихся получило только четверки или пятерки на всех
экзаменах? Ответ на этот вопрос запишите в ячейку B102 таблицы.
2. Для группы учащихся, которые получили только четверки или пятерки на всех
экзаменах, посчитайте средний балл, полученный ими на экзамене по алгебре. Ответ на этот
вопрос запишите в ячейку B103 таблицы.
Полученную таблицу необходимо сохранить под именем, указанным организаторами
экзамена.
Решение
Сначала в столбец G для каждого учащегося запишем логическое значение ложь или
истина в зависимости от того, выполняется ли для него условие первого вопроса. Для этого в
ячейку G2 запишем формулу =ЕСЛИ(И(C2>3;D2>3;E2>3;F2>3);1;0). Скопируем ячейку G2 в
буфер обмена, выделим блок G3:G101 и вставим в этот блок содержимое буфера обмена.
Благодаря использованию относительных ссылок, в столбце G для строк 2–101 будет записан
признак того, выполнено ли для данного учащегося условие первого вопроса. Для того чтобы
подсчитать количество таких учащихся, в ячейку B102 запишем формулу =СУММ(G2:G101).
Затем в столбец H запишем для каждого учащегося его оценку по алгебре, если он
удовлетворяет условию первого вопроса, или значение 0, если он не удовлетворяет условию.
Для этого в ячейку H2 запишем формулу =С2*G2. Скопируем ячейку H2 в буфер обмена,
выделим блок H3:H101 и вставим в этот блок содержимое буфера обмена. Благодаря
использованию относительных ссылок, в столбце H для строк 2–101 будет записана оценка
по алгебре тех учащихся, для которых выполнено условие первого вопроса и число 0 – для
остальных учащихся. Для получения ответа на второй вопрос в ячейку B103 запишем
формулу =СУММ(H2:H101)/B102.
3.
(2011) В электронную таблицу занесли результаты мониторинга стоимости бензина
трех марок (92, 95, 98) на бензозаправках города. На рисунке приведены первые
строки получившейся таблицы:
1
2
3
4
5
A
Улица
Абельмановская
Абрамцевская
Авиамоторная
Авиаторов
B
Марка
92
98
95
95
C
Цена
22,65
25,90
24,55
23,85
В столбце A записано название улицы, на которой расположена бензозаправка, в
столбце B – марка бензина, который продается на этой заправке (одно из чисел 92, 95, 98), в
столбце C – стоимость бензина на данной бензозаправке (в рублях, с указанием двух знаков
дробной части).
На каждой улице может быть расположена только одна заправка, для каждой заправки
указана только одна марка бензина. Всего в электронную таблицу были занесены данные по
1000 бензозаправок. Порядок записей в таблице произвольный.
Выполните задание
Откройте файл с данной электронной таблицей (расположение файла вам сообщат
организаторы экзамена). На основании данных, содержащихся в этой таблице, ответьте на
два вопроса:
1. Какова максимальная цена бензина марки 92? Ответ на этот вопрос запишите в ячейку
E2 таблицы.
2. Сколько бензозаправок продает бензин марки 92 по максимальной цене в городе?
Ответ на этот вопрос запишите в ячейку E3 таблицы.
Полученную таблицу необходимо сохранить под именем, указанным организаторами
экзамена.
Решение
Данную задачу можно решать разными способами. Например, можно отсортировать
таблицу по марке бензина, а при равном значении марки бензина – по цене бензина и найти в
отсортированной таблице множество строк, для которых значение цены бензина марки 92
максимально:
Если задание выполнено правильно и при выполнении задания использовались файлы,
специально подготовленные для проверки выполнения данного задания, то должны
получиться следующие ответы:
На первый вопрос – 23,25.
На второй вопрос – 12.
4. (2012) В электронную таблицу занесли результаты тестирования учащихся по
математике и физике. На рисунке приведены первые строки получившейся таблицы.
1
2
3
4
5
6
A
Ученик
Наумкина Анна
Шевченко Иван
Жуков Михаил
Долбенко Тимур
Насрединов Рамиль
B
Район
Майский
Заречный
Подгорный
Центральный
Заречный
C
Русский язык
17
24
24
26
28
D
Математика
68
6
12
30
49
В столбце A указаны фамилия и имя учащегося; в столбце B – район города, в котором
расположена школа учащегося; в столбцах C, D – баллы, полученные соответственно по
русскому языку и математике. По каждому предмету можно было набрать от 0 до 100 баллов.
Всего в электронную таблицу были занесены данные по 263 учащимся. Порядок записей в
таблице произвольный.
Выполните задание
Откройте файл с данной электронной таблицей (расположение файла Вам сообщат
организаторы экзамена). На основании данных, содержащихся в этой таблице, ответьте на
два вопроса.
1. Чему равна наибольшая сумма баллов по двум предметам среди учащихся Майского
района? Ответ на этот вопрос запишите в ячейку G1 таблицы.
2. Сколько процентов от общего числа участников составили ученики Майского района?
Ответ с точностью до одного знака после запятой запишите в ячейку G2 таблицы.
Полученную таблицу необходимо сохранить под именем, указанным организаторами
экзамена.
Примечание. При решении допускается использование любых возможностей
электронных таблиц. Допускаются вычисления при помощи ручки и бумаги. Использование
калькуляторов не допускается.
Решение
В столбце Е для каждого учащегося вычислим сумму баллов по двум предметам, если
это – ученик Майского района. Для ученика другого района ячейка будет содержать пустую
строку. В ячейку E2 запишем формулу
=ЕСЛИ(B2="Майский";C2+D2;"")
Скопируем формулу во все ячейки диапазона Е3:Е264. Благодаря использованию
относительных ссылок в столбце E в строках 2–264 будут записаны суммы баллов учеников
Майского района.
Для того чтобы найти наибольшую сумму, в ячейку G1 внесѐм формулу
=MАКС(E2:E264)
Для ответа на второй вопрос в дополнительной ячейке, например в H3, найдѐм
количество учеников Майского района, принимавших участие в тестировании. Это можно
сделать различными способами, в том числе при помощи функции
=СЧЁТЕСЛИ(B2:B264;"Майский")
или же посчитав количество числовых значений в диапазоне Е2:Е1001:
=СЧЁТ(E2:E264)
Выразим полученное значение в процентах от общего числа участников тестирования.
Результат запишем в ячейку G2: =H3/263*100
Возможны и другие способы решения задачи.
Если задание выполнено правильно, то должны получиться следующие ответы:
на первый вопрос – 166;
на второй вопрос – 23,6.
5. (2013) В электронную таблицу занесли информацию о грузоперевозках, совершѐнных
некоторым автопредприятием с 1 по 9 октября. Ниже приведены первые пять строк
таблицы.
1
2
3
4
5
A
B
Дата
Пункт
отправления
Липки
Орехово
Осинки
Липки
1 октября
1 октября
1 октября
1 октября
C
D
E
F
Пункт
Расстояние Расход Масса
назначения
бензина груза
Березки
432
63
770
Дубки
121
17
670
Вязово
333
47
830
Вязово
384
54
730
Каждая строка таблицы содержит запись об одной перевозке. В столбце A записана
дата перевозки (от «1 октября» до «9 октября»); в столбце B – название населѐнного пункта
отправления перевозки; в столбце C – название населѐнного пункта назначения перевозки; в
столбце D – расстояние, на которое была осуществлена перевозка (в километрах); в столбце
E – расход бензина на всю перевозку (в литрах); в столбце F – масса перевезѐнного груза (в
килограммах).
Всего в электронную таблицу были занесены данные по 370 перевозкам в
хронологическом порядке.
Выполните задание
Откройте файл с данной электронной таблицей (расположение файла Вам сообщат
организаторы экзамена). На основании данных, содержащихся в этой таблице, ответьте на
два вопроса.
1. На какое суммарное расстояние были произведены перевозки с 1 по 3 октября? Ответ
на этот вопрос запишите в ячейку H2 таблицы.
2. Какова средняя масса груза при автоперевозках, осуществлѐнных из города Липки?
Ответ на этот вопрос запишите в ячейку H3 таблицы с точностью не менее одного знака
после запятой.
Полученную таблицу необходимо сохранить под именем, указанным организаторами
экзамена.
Решение
В ячейку H2 необходимо записать формулу
=СУММ(D2:D118)
В ячейку H3 необходимо записать формулу
=СУММЕСЛИ(B2:B371;"Липки";F2:F371)/СЧЁТЕСЛИ(B2:B371;"Липки")
Возможны и другие варианты решения, например сортировка строк по значению
столбца B с последующим заданием правильных блоков для функций.
Если задание выполнено правильно, то должны получиться следующие ответы:
На первый вопрос: 28468.
На второй вопрос: 760,9
Скачать